ELT Buzzer continues on without ELT Activation

More
3 weeks 3 days ago - 3 weeks 3 days ago #1455 by Emblemdhc
Dear team During aircraft power up I noticed ELT buzzer sound in the tail cone so I checked ELT  for activation but it is not activated (No LED indication ) on external remote switch and ELT  So we turned off the battery and buzzer Sound stop   Now again power up aircraft so now I access the ELT and disconnect molex connector on ELT and buzzer sound stop 
Now remove the ELT and refer Aircraft wiring manual  buzzer power is provide by ELT Now we check voltage on ELT on PIN NO. 2&4 showing 12 VDC
First thing is clear ELT is Faulty 
Now second thing is why buzzer is activate during aircraft power on
Aircraft only provide 28 VDC for remote switch LED (on indication)  

This browser does not support PDFs. Please download the PDF to view it: Download PDF


 
 

This browser does not support PDFs. Please download the PDF to view it: Download PDF

Last edit: 3 weeks 3 days ago by Emblemdhc.

Please Log in or Create an account to join the conversation.

More
3 weeks 21 hours ago - 3 weeks 21 hours ago #1462 by Mark
Have you hit the unit with any force? Could the G-Switch be possibly activated? Disconnect one end of loop. See if problem continues.

There are two reset wires..... have those been checked.
  
  
 
  
 
Last edit: 3 weeks 21 hours ago by Mark.

Please Log in or Create an account to join the conversation.

More
3 weeks 16 hours ago #1463 by Emblemdhc
Sir we did not hit the ELT Actually aircraft in Hanger for maintenance so during aircraft power on I noticed sound was coming from the buzzer
G-switch is not active and ELT Is also not active but buzzer sound comes only when we power up the aircraft 
Buzzer power is provide by ELT but why its turn on while power up the aircraft 

Please Log in or Create an account to join the conversation.

More
3 weeks 16 hours ago #1464 by Mark
How long does it stay on? How do you get it to turn off? Do you here a tone on 121.50?

I'd still disconnect one end of the loop wire to see if it stops.

Please Log in or Create an account to join the conversation.

More
3 weeks 16 hours ago #1465 by Emblemdhc
We are not getting tone on 121.5 MHz 
We any getting only buzzer sound
buzzer only sound when  we Turn on aircraft battery and when we turn off aircraft battery buzzer will stop 
we are unable to reset 

 

Please Log in or Create an account to join the conversation.

More
3 weeks 16 hours ago #1466 by Mark
If no 121.50 signal, ELT is not activated.
If the buzzer stops when you disconnect the ELT plug going to it..... then it must be the ELT itself.

Please Log in or Create an account to join the conversation.

More
3 weeks 16 hours ago #1467 by Emblemdhc
Yes sir  ELT is faulty 
But second thing is why buzzer only sound when we turn on aircraft battery 
as per wiring diagram Buzzer power is provided by ELT then buzzer should always be on even if we turn off the battery
Sir what do you think about it 
 

Please Log in or Create an account to join the conversation.

More
3 weeks 15 hours ago #1468 by Mark
From the prints, it looks like you've got 5.6 volts present on ELT. I don't know if this is a charging voltage (if there is one) coming from the aircraft or if it starts at ELT.
I would think the aircraft is providing it.
Also..... without having access to the manuals, this might be a low ELT battery indication.

Please Log in or Create an account to join the conversation.

More
3 weeks 15 hours ago #1469 by Emblemdhc
Low battery indication is provided by 7 flash on LED so its not Battey low
PT514 is ELT/Nav interface unit its providing GPS data to ELT 
5 volt is not for charging but I don know what it is for 
 

Please Log in or Create an account to join the conversation.

Time to create page: 0.879 seconds